Ik kan geen account aanmaken met FireFox?

Het Bel-me-niet Register ondersteunt het gebruik van FireFox. Dit geldt ook voor de nieuwste versie van FireFox. In principe moet u met de standaard FireFox, zonder de extra plugins, gewoon kunnen inloggen.

Controleer of u een advertentieonderdrukker aan heeft staan? Adblock Plus bijvoorbeeld? Een storende factor zouden de extra geïnstalleerde plugins kunnen zijn. Daarom verzoeken wij u aan ons een lijst te zenden met de plugins die bij u zijn geïnstalleerd? Deze kunnen wij gebruiken om uw probleem verder te analyseren.

De lijst van plug-ins vindt u onder de knop Extra -> Add-ons -> Plug-ins.